package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[-^]`)
var str = `- #start with "-" in the bracket
^ #don't start with "^" in the bracket
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}