re = /[-^]/m
str = '- #start with "-" in the bracket
^ #don\'t start with "^" in the bracket
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end