$re = '/[^:]+:[^:]+$/m';
$str = 'cpe:/o:redhat:enterprise_linux:7
cpe:/o:centos:centos:7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);