re = /[^:]+:[^:]+$/m
str = 'cpe:/o:redhat:enterprise_linux:7
cpe:/o:centos:centos:7'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end