package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\$([a-z0-9_]+)`)
var str = `BitOR($SS_SUNKEN, $SS_CENTERIMAGE))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}