package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(2\)\s(\d+[,.]\d+(?:[.]\d+)?)`)
var str = `(2) 1,127.22 abcdfg sdkjf 20,200.01 abcdfg sdfkgj (2) 10.28`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}