re = /\(2\)\s(\d+[,.]\d+(?:[.]\d+)?)/
str = '(2) 1,127.22 abcdfg sdkjf 20,200.01 abcdfg sdfkgj (2) 10.28'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end