package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\?v(?:er)?\b`)
var str = ` "?ver" and "?v", but not the word "?version"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}