using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"dialog(?! box)";
string input = @"Look at the dialog box.
Look at the dialog.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}