$re = '/dialog(?! box)/m';
$str = 'Look at the dialog box.
Look at the dialog.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);