#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[A-Z]{2} \d{6}(?!\d)|(?<!\S)\d{4,}(?!\S))"
Local $sString = "1st Prize Rs :120000000/- 1) XG 218582 (KOTTAYAM)" & @CRLF & _
"Cons Prize-Rs :500000/- XA 218582XB 218582XC 218582XD 218582XE 218582" & @CRLF & _
"2nd Prize Rs :5000000/- 1) XA 788417 (THRISSUR)" & @CRLF & _
"2) XB 161796 (ADIMALY)" & @CRLF & _
"3) XC 319503 (ATTINGAL)" & @CRLF & _
"4) XD 713832 (KOTTAYAM)" & @CRLF & _
"5) XE 667708 (KOTTAYAM)" & @CRLF & _
"6) XG 137764 (NEYYATTINKARA)" & @CRLF & _
"3rd Prize Rs :1000000/- 1) XA 787512 (THRISSUR)" & @CRLF & _
"2) XB 771674 (WAYANADU)" & @CRLF & _
"3) XC 159927 (PALAKKAD)" & @CRLF & _
"4) XD 261430 (ERNAKULAM)" & @CRLF & _
"5) XE 632559 (THIRUR)" & @CRLF & _
"6) XG 232661 (KOLLAM)" & @CRLF & _
"4th Prize Rs :500000/- 1) XA 741906 (ATTINGAL)" & @CRLF & _
"2) XB 145409 (MANANTHAVADY)" & @CRLF & _
"3) XC 489704 (KARUNAGAPALLY)" & @CRLF & _
"4) XD 184478 (KOZHIKKODE)" & @CRLF & _
"5) XE 848905 (NEYYATTINKARA)" & @CRLF & _
"6) XG 839293 (KAYAMKULAM)" & @CRLF & _
"FOR THE TICKETS ENDING WITH THE FOLLOWING NUMBERS" & @CRLF & _
"5th Prize Rs :100000/- 1) 07225" & @CRLF & _
"16/01/2022 16:31:15 IT Support : NIC Kerala Page 1" & @CRLF & _
"2) 65420" & @CRLF & _
"6th Prize-Rs :5000/- 0274 0461 0836 1182 1862" & @CRLF & _
"1953 3116 3869 4355 4532" & @CRLF & _
"4630 4821 5478 5483 6292" & @CRLF & _
"6341 6449 6644 6884 6976" & @CRLF & _
"7313 8117 8229 8508 8692" & @CRLF & _
"8851 9060 9365 9595 9996" & @CRLF & _
"7th Prize-Rs :3000/- 1183 1416 1514 1994 2578" & @CRLF & _
"2858 2879 3115 3159 3270" & @CRLF & _
"3605 3624 4029 4114 4256" & @CRLF & _
"4327 4768 5074 5446 5676" & @CRLF & _
"5784 5921 6528 6552 6611" & @CRLF & _
"6664 6900 7576 7819 7998" & @CRLF & _
"8011 8918 8923 8929 9787" & @CRLF & _
"9974" & @CRLF & _
"8th Prize-Rs :2000/- 0095 0114 0422 0596 1086" & @CRLF & _
"1363 1492 2391 2411 2439" & @CRLF & _
"2716 2807 2850 3285 3399" & @CRLF & _
"3460 3559 3562 3828 4414" & @CRLF & _
"4632 4672 4812 5096 5158" & @CRLF & _
"5388 6913 7464 7626 7827" & @CRLF & _
"7841 8542 8717 9632 9703" & @CRLF & _
"9712" & @CRLF & _
"9th Prize-Rs :1000/- 0022 0076 0164 0237 0242" & @CRLF & _
"0307 0361 0364 0379 0438" & @CRLF & _
"0439 0452 0516 0544 0547" & @CRLF & _
"0577 0603 0647 0659 0680" & @CRLF & _
"0709 0742 0759 0789 0810" & @CRLF & _
"0859 0920 1060 1062 1090" & @CRLF & _
"16/01/2022 16:31:15 IT Support : NIC Kerala Page 2" & @CRLF & _
"1105 1126 1173 1181 1347" & @CRLF & _
"1389 1420 1448 1526 1667" & @CRLF & _
"1712 1775 1793 1821 1827" & @CRLF & _
"1874 1882 1942 1954 2026" & @CRLF & _
"2042 2054 2072 2074 2107" & @CRLF & _
"2115 2116 2150 2154 2207" & @CRLF & _
"2230 2318 2378 2387 2389" & @CRLF & _
"2490 2536 2586 2616 2656" & @CRLF & _
"2731 2835 2893 2921 2937" & @CRLF & _
"2953 2996 3049 3082 3131" & @CRLF & _
"3132 3147 3172 3179 3186" & @CRLF & _
"3196 3198 3235 3277 3324" & @CRLF & _
"3340 3355 3383 3392 3459" & @CRLF & _
"3467 3468 3522 3528 3545" & @CRLF & _
"3549 3581 3665 3666 3769" & @CRLF & _
"3850 3896 3911 3969 4056" & @CRLF & _
"4085 4094 4147 4154 4189" & @CRLF & _
"4326 4381 4537 4557 4582" & @CRLF & _
"4631 4667 4762 4770 4788" & @CRLF & _
"4820 4888 4928 4950 5020" & @CRLF & _
"5031 5198 5217 5244 5253" & @CRLF & _
"5271 5418 5427 5501 5549" & @CRLF & _
"5587 5698 5707 5717 5760" & @CRLF & _
"5763 5826 5827 5857 5923" & @CRLF & _
"5932 5958 5985 6046 6049" & @CRLF & _
"6057 6100 6171 6228 6287" & @CRLF & _
"6309 6347 6374 6378 6450" & @CRLF & _
"6483 6487 6529 6533 6568" & @CRLF & _
"6651 6662 6698 6715 6733" & @CRLF & _
"16/01/2022 16:31:16 IT Support : NIC Kerala Page 3" & @CRLF & _
"6763 6811 6891 6960 6971" & @CRLF & _
"6977 6979 7001 7037 7068" & @CRLF & _
"7105 7135 7157 7177 7216" & @CRLF & _
"7224 7447 7513 7540 7612" & @CRLF & _
"7675 7685 7717 7729 7814" & @CRLF & _
"7822 7823 7870 7876 7914" & @CRLF & _
"7921 7952 7964 8028 8120" & @CRLF & _
"8131 8141 8145 8151 8185" & @CRLF & _
"8195 8203 8228 8230 8238" & @CRLF & _
"8284 8304 8483 8614 8622" & @CRLF & _
"8623 8697 8839 8859 8860" & @CRLF & _
"8922 8979 9020 9026 9115" & @CRLF & _
"9135 9137 9140 9220 9297" & @CRLF & _
"9359 9364 9371 9456 9516" & @CRLF & _
"9529 9626 9664 9680 9701" & @CRLF & _
"9711 9836" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")