import Foundation
let pattern = #"(?:[A-Z]{2} \d{6}(?!\d)|(?<!\S)\d{4,}(?!\S))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1st Prize Rs :120000000/- 1) XG 218582 (KOTTAYAM)
Cons Prize-Rs :500000/- XA 218582XB 218582XC 218582XD 218582XE 218582
2nd Prize Rs :5000000/- 1) XA 788417 (THRISSUR)
2) XB 161796 (ADIMALY)
3) XC 319503 (ATTINGAL)
4) XD 713832 (KOTTAYAM)
5) XE 667708 (KOTTAYAM)
6) XG 137764 (NEYYATTINKARA)
3rd Prize Rs :1000000/- 1) XA 787512 (THRISSUR)
2) XB 771674 (WAYANADU)
3) XC 159927 (PALAKKAD)
4) XD 261430 (ERNAKULAM)
5) XE 632559 (THIRUR)
6) XG 232661 (KOLLAM)
4th Prize Rs :500000/- 1) XA 741906 (ATTINGAL)
2) XB 145409 (MANANTHAVADY)
3) XC 489704 (KARUNAGAPALLY)
4) XD 184478 (KOZHIKKODE)
5) XE 848905 (NEYYATTINKARA)
6) XG 839293 (KAYAMKULAM)
FOR THE TICKETS ENDING WITH THE FOLLOWING NUMBERS
5th Prize Rs :100000/- 1) 07225
16/01/2022 16:31:15 IT Support : NIC Kerala Page 1
2) 65420
6th Prize-Rs :5000/- 0274 0461 0836 1182 1862
1953 3116 3869 4355 4532
4630 4821 5478 5483 6292
6341 6449 6644 6884 6976
7313 8117 8229 8508 8692
8851 9060 9365 9595 9996
7th Prize-Rs :3000/- 1183 1416 1514 1994 2578
2858 2879 3115 3159 3270
3605 3624 4029 4114 4256
4327 4768 5074 5446 5676
5784 5921 6528 6552 6611
6664 6900 7576 7819 7998
8011 8918 8923 8929 9787
9974
8th Prize-Rs :2000/- 0095 0114 0422 0596 1086
1363 1492 2391 2411 2439
2716 2807 2850 3285 3399
3460 3559 3562 3828 4414
4632 4672 4812 5096 5158
5388 6913 7464 7626 7827
7841 8542 8717 9632 9703
9712
9th Prize-Rs :1000/- 0022 0076 0164 0237 0242
0307 0361 0364 0379 0438
0439 0452 0516 0544 0547
0577 0603 0647 0659 0680
0709 0742 0759 0789 0810
0859 0920 1060 1062 1090
16/01/2022 16:31:15 IT Support : NIC Kerala Page 2
1105 1126 1173 1181 1347
1389 1420 1448 1526 1667
1712 1775 1793 1821 1827
1874 1882 1942 1954 2026
2042 2054 2072 2074 2107
2115 2116 2150 2154 2207
2230 2318 2378 2387 2389
2490 2536 2586 2616 2656
2731 2835 2893 2921 2937
2953 2996 3049 3082 3131
3132 3147 3172 3179 3186
3196 3198 3235 3277 3324
3340 3355 3383 3392 3459
3467 3468 3522 3528 3545
3549 3581 3665 3666 3769
3850 3896 3911 3969 4056
4085 4094 4147 4154 4189
4326 4381 4537 4557 4582
4631 4667 4762 4770 4788
4820 4888 4928 4950 5020
5031 5198 5217 5244 5253
5271 5418 5427 5501 5549
5587 5698 5707 5717 5760
5763 5826 5827 5857 5923
5932 5958 5985 6046 6049
6057 6100 6171 6228 6287
6309 6347 6374 6378 6450
6483 6487 6529 6533 6568
6651 6662 6698 6715 6733
16/01/2022 16:31:16 IT Support : NIC Kerala Page 3
6763 6811 6891 6960 6971
6977 6979 7001 7037 7068
7105 7135 7157 7177 7216
7224 7447 7513 7540 7612
7675 7685 7717 7729 7814
7822 7823 7870 7876 7914
7921 7952 7964 8028 8120
8131 8141 8145 8151 8185
8195 8203 8228 8230 8238
8284 8304 8483 8614 8622
8623 8697 8839 8859 8860
8922 8979 9020 9026 9115
9135 9137 9140 9220 9297
9359 9364 9371 9456 9516
9529 9626 9664 9680 9701
9711 9836
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)