#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)((?:\d+)|(?:\d+[,.]\d+))\s*([a-z]+)"
Local $sString = "1litru" & @CRLF & _
"1 litru" & @CRLF & _
"1 capsula" & @CRLF & _
"" & @CRLF & _
"1.2 kg" & @CRLF & _
"1.2kg" & @CRLF & _
"" & @CRLF & _
"1,2kg" & @CRLF & _
"1,2capsule" & @CRLF & _
"" & @CRLF & _
"Omega-3, L-Carnitina"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")