package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)((?:\d+)|(?:\d+[,.]\d+))\s*([a-z]+)`)
var str = `1litru
1 litru
1 capsula
1.2 kg
1.2kg
1,2kg
1,2capsule
Omega-3, L-Carnitina`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}