#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/(?:w{3})?kwagmire\.com\/embed\/([a-zA-Z0-9]+)\/?$"
Local $sString = "https://kwagmire.com/embed/1QgJVmCam" & @CRLF & _
"http://kwagmire.com/embed/1QgJVmCam" & @CRLF & _
"https://kwagmire.com/embed/1QgJVmCam/" & @CRLF & _
"http://kwagmire.com/embed/1QgJVmCam/" & @CRLF & _
"https.evil.com/http://jsitor.com/embed/1QgJVmCam" & @CRLF & _
"facebook.com" & @CRLF & _
"https://google.com" & @CRLF & _
"www.twitter.com" & @CRLF & _
"http://kwagmire.com/embed/1QgJVmCam/?onload(alert('asdfadsf'))" & @CRLF & _
"http://kwagmire.com/embed/1QgJVmCam/ onload(alert('asdfadsf'))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")