package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?:\/\/(?:w{3})?kwagmire\.com\/embed\/([a-zA-Z0-9]+)\/?$`)
var str = `https://kwagmire.com/embed/1QgJVmCam
http://kwagmire.com/embed/1QgJVmCam
https://kwagmire.com/embed/1QgJVmCam/
http://kwagmire.com/embed/1QgJVmCam/
https.evil.com/http://jsitor.com/embed/1QgJVmCam
facebook.com
https://google.com
www.twitter.com
http://kwagmire.com/embed/1QgJVmCam/?onload(alert('asdfadsf'))
http://kwagmire.com/embed/1QgJVmCam/ onload(alert('asdfadsf'))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}