import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"event_sub_type\\\":\\\"((WAN\\s+Firewall)|TLS)";
final String string = "1. event_sub_type\":\"WAN\n\n"
+ " \n\n"
+ "{\"event_count\":1,\"ISP_name\":\"Shanghai internet\",\"rule\":\"Initial Connectivity Rule\",\"dest_is_site_or_vpn\":\"Site\",\"src_isp_ip\":\"0.0.0.0\",\"time_str\":\"2023-11-28T04:27:40Z\",\"src_site\":\"CHINA-AZURE-E2\",\"src_ip\":\"0.0.0.1\",\"internalId\":\"54464646\",\"dest_site_name\":\"china_112,\"event_type\":\"Security\",\"src_country_code\":\"CN\",\"action\":\"Monitor\",\"subnet_name\":\"cn-001.net-vnet-1\",\"pop_name\":\"Shanghai_1\",\"dest_port\":443,\"dest_site\":\"china_connect\",\"rule_name\":\"Initial Connectivity Rule\",\"event_sub_type\":\"WAN Firewall\",\"insertionDate\":1701188916690,\"ip_protocol\":\"TCP\",\"rule_id\":\"101238\",\"src_is_site_or_vpn\":\"Site\",\"account_id\":5555,\"application\":\"HTTP(S)\",\"src_site_name\":\"china_connect\",\"src_country\":\"China\",\"dest_ip\":\"0.0.0.0\",\"os_type\":\"OS_ANDROID\",\"app_stack\"\"TCP\",\"TLS\",\"HTTP(S)\"],\"time\":1701188860834}\n\n"
+ " \n\n"
+ "2. \"event_sub_type\":\"TLS\",\"\n\n"
+ " \n\n"
+ "{\"event_count\":4,\"http_host_name\":\"isp.vpn\",\"ISP_name\":\"China_internet\",\"src_isp_ip\":\"0.0.0.0\",\"tls_version\":\"TLSv1.3\",\"time_str\":\"2023-11-28T04:27:16Z\",\"src_site\":\"china_mtt\",\"src_ip\":\"0.0.0.0\",\"internalId\":\"rtrgrtr\",\"domain_name\":\"china.gh.com\",\"event_type\":\"Security\",\"src_country_code\":\"CN\",\"tls_error_description\":\"unknown CA\",\"action\":\"Alert\",\"subnet_name\":\"0.0.0.0/24\",\"pop_name\":\"china_1\",\"dest_port\":443,\"event_sub_type\":\"TLS\",\"insertionDate\":1701188915580,\"dest_country_code\":\"SG\",\"tls_error_type\":\"fatal\",\"dns_name\":\"china.com\",\"traffic_direction\":\"OUTBOUND\",\"src_is_site_or_vpn\":\"Site\",\"account_id\":56565,\"application\":\"Netskope\",\"src_site_name\":\"CHINA-44\",\"src_country\":\"China\",\"dest_ip\":\"0.0.0.0\",\"os_type\":\"OS_WINDOWS\",\"time\":1701188836011,\"dest_country\":\"Singapore\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}