$re = '/Data Name=\'RuleName\'>technique_id=(?<technique_id>[^,]+),technique_name=(?<technique_name>[^<]+)</m';
$str = '<Data Name=\'RuleName\'>-</Data>
<Data Name=\'EventType\'>SetValue</Data>
<Data Name=\'UtcTime\'>2022-03-24 06:12:51.184</Data>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);