re = /Data Name='RuleName'>technique_id=(?<technique_id>[^,]+),technique_name=(?<technique_name>[^<]+)</m
str = '<Data Name=\'RuleName\'>-</Data>
<Data Name=\'EventType\'>SetValue</Data>
<Data Name=\'UtcTime\'>2022-03-24 06:12:51.184</Data>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end