$re = '/\d+[\u00A0]*/';
$str = '1000 kr';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);