import re
regex = re.compile(r"(font-family):\s*([^;]*)[;'][;\"]")
test_str = ("<span style=\"color: red;font-family:'Sanc';\">test</span>\n"
"<span style=\"font-family:'Sanc';color: red;\">test</span>\n"
"<span style=\"font-family:'Sanc'\">test</span>\n"
"<span style=\"color: red;font-family:'Sanc';line-height: 15px;\">test</span>")
subst = "\""
result = regex.sub(subst, test_str)
if result:
print(result)