re = /^(?!\/).*(*SKIP)(*F)|e/m
str = '/zombie nimble zombie quick
Plants vs Zombies reference'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end