re = /\h{3}-\h(\S)/m
str = '- Right? Yeah? - Yeah.
- What\'s your name? - I\'m... I\'m Caleb.
- I\'m Christina. - Beatrice.'
subst = ' - $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result