using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"anchor.{,5}test:""([\d.]+)""";
string input = @"ahlkhsa-anchorawO&B6o77ooiynlhwlkfnbla,)9;}[test:""ajanchorkh,2Yio98vacpoi [p{7}]test:""2""*iuyanchorap07A(p)a test:""*^g8p9JiguanchorLI;ntest:""9.3""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}