import re
regex = re.compile(r'anchor.{,5}test:"([\d.]+)"', flags=re.MULTILINE)
test_str = "ahlkhsa-anchorawO&B6o77ooiynlhwlkfnbla,)9;}[test:\"\"ajanchorkh,2Yio98vacpoi [p{7}]test:\"2\"*iuyanchorap07A(p)a test:\"\"*^g8p9JiguanchorLI;ntest:\"9.3\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")