$re = '/\[([a-z0-9]+)(?:(?!\[\1\b).)+?\[\/\1\]/i';
$str = 'Lorem ipsum dolor sit amet, [color] consectetur adipisicing el it labore et [color=red]dolore magna aliqua[/color] minim veniam.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);