re = /\[([a-z0-9]+)(?:(?!\[\1\b).)+?\[\/\1\]/i
str = 'Lorem ipsum dolor sit amet, [color] consectetur adipisicing el it labore et [color=red]dolore magna aliqua[/color] minim veniam.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end