$re = '/^\s*?((?:virtual\s+|const\s+|friend\s+|volatile){0,3}\s*(?:\w+\s*::\s*)?\s*[\w]*?)\s*\w+\s*::\s*(~?[\w]+)\s*(\(.*\))\s*(const)?\s*[{|:]/m';
$str = '#include <iostream>
#include <iomanip>
#include "Time.h"
using namespace std;
Time :: ~Time(const int h, const int m, const int s)
: hour(h), minute (m), second(s)
{}
virtual const std::void Time :: setTime(const int h, const int m, const int s)
{
hour = h;
minute = m;
second = s;
}
std::string Time :: print() const
{
cout << setw(2) << setfill(\'0\') << hour << ":"
<< setw(2) << setfill(\'0\') << minute << ":"
<< setw(2) << setfill(\'0\') << second << "\\n";
}
bool Time :: equals(const Time &otherTime)
{
if(hour == otherTime.hour
&& minute == otherTime.minute
&& second == otherTime.second)
return true;
else
return false;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);