# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*?((?:virtual\s+|const\s+|friend\s+|volatile){0,3}\s*(?:\w+\s*::\s*)?\s*[\w]*?)\s*\w+\s*::\s*(~?[\w]+)\s*(\(.*\))\s*(const)?\s*[{|:]"
test_str = ("#include <iostream>\n"
"#include <iomanip>\n"
"#include \"Time.h\"\n"
"using namespace std;\n\n"
"Time :: ~Time(const int h, const int m, const int s) \n"
" : hour(h), minute (m), second(s)\n"
"{}\n\n"
"virtual const std::void Time :: setTime(const int h, const int m, const int s) \n"
"{\n"
" hour = h;\n"
" minute = m;\n"
" second = s; \n"
"} \n"
" \n"
"std::string Time :: print() const\n"
"{\n"
" cout << setw(2) << setfill('0') << hour << \":\"\n"
" << setw(2) << setfill('0') << minute << \":\"\n"
" << setw(2) << setfill('0') << second << \"\\n\"; \n"
" \n"
"}\n"
" \n"
"bool Time :: equals(const Time &otherTime)\n"
"{\n"
" if(hour == otherTime.hour \n"
" && minute == otherTime.minute \n"
" && second == otherTime.second)\n"
" return true;\n"
" else\n"
" return false;\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.