import re
regex = re.compile(r"^(?:(?:.*?<p class=\"test_formal\">(?:(?!<span class=\"test_formal2\">).)*)|(?:(?!<p class=\"test_formal\">).)*<span class=\"test_formal2\">.*)$", flags=re.MULTILINE)
test_str = ("<p class=\"test_formal\">\n"
"<span class=\"test_formal2\">\n"
"<p class=\"test_formal\"><span class=\"test_formal2\">\n"
"blah <p class=\"test_formal\"><span class=\"test_formal2\"> blah blah\n"
"<span class=\"test_formal2\"><p class=\"test_formal\">\n"
"blah blah <span class=\"test_formal2\"><p class=\"test_formal\"> blah blah\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")