re = /^(?:(?:.*?<p class="test_formal">(?:(?!<span class="test_formal2">).)*)|(?:(?!<p class="test_formal">).)*<span class="test_formal2">.*)$/m
str = '<p class="test_formal">
<span class="test_formal2">
<p class="test_formal"><span class="test_formal2">
blah <p class="test_formal"><span class="test_formal2"> blah blah
<span class="test_formal2"><p class="test_formal">
blah blah <span class="test_formal2"><p class="test_formal"> blah blah
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end