$re = '/\s*([^.]+(?=\([\w ,.]+(, *\?)?(\d{4}|\d{2})\)\.?))(\([\w ,.]+(, *\?)?(\d{4}|\d{2})\)\.?)/m';
$str = '"Nothing is here. In this line, actually, there is a citation (Author et al., 2022). Once again, In this line there is nothing."
Other lines with parenthesis (but they do not match because of missing year).
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);