import re
regex = re.compile(r"(?i)\s((?:https?:\/\/|www\d{0,3}[.]|[a-z0-9.\-]+[.][a-z]{2,4}\/)(?:[^\s()<>]+|\(([^\s()<>]+|(\([^\s()<>]+\)))*\))+(?:\(([^\s()<>]+|(\([^\s()<>]+\)))*\)|[^\s`!()\[\]{};:'\".,<>?«»“”‘’]))", flags=re.MULTILINE)
test_str = ("<a href=\"https://example.com/page.php?goto=200\">https://example.com/page.php?goto=200</a>The problem occurs when I have almost identical links. For example: https://example.com/page.php?goto=200 and https://example.com/page.php\n"
"<a href=\"https://example.com/page.php?goto=200\">https://example.com/page.php?goto=200</a>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")