re = /(?i)\s((?:https?:\/\/|www\d{0,3}[.]|[a-z0-9.\-]+[.][a-z]{2,4}\/)(?:[^\s()<>]+|\(([^\s()<>]+|(\([^\s()<>]+\)))*\))+(?:\(([^\s()<>]+|(\([^\s()<>]+\)))*\)|[^\s`!()\[\]{};:'\".,<>?«»“”‘’]))/m
str = '<a href="https://example.com/page.php?goto=200">https://example.com/page.php?goto=200</a>The problem occurs when I have almost identical links. For example: https://example.com/page.php?goto=200 and https://example.com/page.php
<a href="https://example.com/page.php?goto=200">https://example.com/page.php?goto=200</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end