#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(https?:\/\/)?([a-z0-9]+(-[a-z0-9]+)*\.)+[a-z]{2,}[^\/\s]+"
Local $sString = "" & @CRLF & _
"Google" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"повезло" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ВсеКартинкиВидеоНовостиКартыЕщё" & @CRLF & _
"НастройкиИнструменты" & @CRLF & _
"Результатов: примерно 34 400 000 (0,32 сек.) " & @CRLF & _
"Результаты поиска" & @CRLF & _
"ПОВЕЗЛО ТАК ПОВЕЗЛО подборка ( нереальное везение ..." & @CRLF & _
"Видео по запросу повезло▶ 5:24" & @CRLF & _
"https://www.youtube.com/watch?v=TR-XlvXyVVk" & @CRLF & _
"9 июн. 2016 г. - Добавлено пользователем UGARPRIKOL" & @CRLF & _
"Подборка везений, удач, людей рожденных в рубашке, невероятные везунчики, нереальное везение, спасения, невероятные случаи, нереальные спасения, удивительные случаи ..." & @CRLF & _
"Повезло так повезло - YouTube" & @CRLF & _
"Видео по запросу повезло▶ 4:02" & @CRLF & _
"https://www.youtube.com/watch?v=0fCer7MSsGE" & @CRLF & _
"5 янв. 2016 г. - Добавлено пользователем CrazyLife" & @CRLF & _
"Текст повезло так повезло: Многие люди жалуются на судьбу, но не все знают что бывают случаи из категории повезло так повезло, вот часто такие случаи повезло..." & @CRLF & _
"Люди которым очень повезло - YouTube" & @CRLF & _
"Видео по запросу повезло▶ 13:33" & @CRLF & _
"http://www.youtube.com/watch?v=WT5rSmyDUPE" & @CRLF & _
"http://www.i-am-first.and-me-02.com" & @CRLF & _
"9 нояб. 2014 г. - Добавлено пользователем zrelishhe" & @CRLF & _
"Люди которым очень повезло. https://www.youtube.com/playlist?list=PLaAsJPdpb4MdBCu1s-990Zb0atgzMH-VC Каждый ..." & @CRLF & _
"Мне повезло - Перевод на английский - примеры русский | Reverso ..." & @CRLF & _
"context.reverso.net/перевод/русский-английский/Мне+повезло" & @CRLF & _
"Перевод контекст "Мне повезло" c русский на английский от Reverso Context: мне очень повезло, мне так повезло, мне не повезло, мне просто повезло." & @CRLF & _
"Я думаю, мне повезло - Перевод на английский - примеры русский ..." & @CRLF & _
"context.reverso.net/перевод/русский-английский/Я+думаю%2C+мне+повезло" & @CRLF & _
"Перевод контекст "Я думаю, мне повезло" c русский на английский от Reverso Context: Я думаю, мне повезло, что Эмили не колдунья." & @CRLF & _
"Тебе повезло - Перевод на английский - примеры русский ..." & @CRLF & _
"context.reverso.net/перевод/русский-английский/Тебе+повезло" & @CRLF & _
"Перевод контекст "Тебе повезло" c русский на английский от Reverso Context: повезло тебе, тебе не повезло, тебе очень повезло." & @CRLF & _
"Ему повезло - Перевод на английский - примеры русский | Reverso ..." & @CRLF & _
"context.reverso.net/перевод/русский-английский/Ему+повезло" & @CRLF & _
"Перевод контекст "Ему повезло" c русский на английский от Reverso Context: Ему повезло я не делал промывание желудка." & @CRLF & _
"25 человек, на голову которых свалилась огромная удача - AdMe" & @CRLF & _
"https://www.adme.ru/.../25-chelovek-na-golovu-kotoryh-svalilas-ogromnaya-udacha-..." & @CRLF & _
"21 ч. назад - 25 человек, которым крупно повезло, и они не смогли держать это в тайне · 10 034 · 12 «отвратительных» валентинок для тех, кто сыт по горло ванильными подарками · 11 990 · 6 важных нюансов, которыми стоматологи не спешат делиться с пациентами · 41 621 · 25 преподавателей, круче ..." & @CRLF & _
"Люди, которым "немножко" не повезло | NUR.KZ" & @CRLF & _
"https://www.nur.kz › ✔ Последние новости › Калейдоскоп" & @CRLF & _
"1 ч. назад - Удача, как известно, дама переменчивая и лучше с ней дружить, чем наоборот. Люди, которым "немножко" не повезло. Подборка, собранная для вас ниже, как раз о том, когда удача отвернулась и людям как минимум "немного" не повезло..." & @CRLF & _
"ПОВЕЗЛО GIF | ГИФКИ | ВКонтакте" & @CRLF & _
"https://vk.com/show_povezlo" & @CRLF & _
"ПОВЕЗЛО GIF | ГИФКИ запись закреплена. вчера в 23:45. Действия. Пожаловаться. БИОМУСОР - ЭТО САМЫЕ ОТБОРНЫЕ МАРГИНАЛЬНЫЕ ЛИЧНОСТИ В РЕЖИМЕ НОН СТОП. ТРЭШОВЫЕ ВИДЮХИ ПИКЧИ БЫДЛО С КОТОРЫХ ХОЧЕТСЯ СВАЛИТЬ С ЭТОЙ ПЛАНЕТЫ БИОМУСОР - https://vk.com/ ..." & @CRLF & _
"Вместе с повезло часто ищут" & @CRLF & _
"повезло перевод" & @CRLF & _
"" & @CRLF & _
"повезло викисловарь" & @CRLF & _
"" & @CRLF & _
"повезло это" & @CRLF & _
"" & @CRLF & _
"повезло горбачева" & @CRLF & _
"" & @CRLF & _
"повезло песня" & @CRLF & _
"" & @CRLF & _
"повезло часть речи" & @CRLF & _
"" & @CRLF & _
"повезло так повезло запятая" & @CRLF & _
"" & @CRLF & _
"видео повезло песня" & @CRLF & _
"" & @CRLF & _
"1 " & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"4" & @CRLF & _
"5" & @CRLF & _
"6" & @CRLF & _
"7" & @CRLF & _
"8" & @CRLF & _
"9" & @CRLF & _
"10" & @CRLF & _
"Следующая" & @CRLF & _
"Казахстан Ауэзовский район, Алматы - Из вашей истории поиска - Учитывать мое местоположение - Подробнее…" & @CRLF & _
"СправкаОтправить отзывКонфиденциальностьУсловия"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")