# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(https?:\/\/)?([a-z0-9]+(-[a-z0-9]+)*\.)+[a-z]{2,}[^\/\s]+"
test_str = ("\n"
"Google\n\n\n"
"повезло\n\n\n"
"ВсеКартинкиВидеоНовостиКартыЕщё\n"
"НастройкиИнструменты\n"
"Результатов: примерно 34 400 000 (0,32 сек.) \n"
"Результаты поиска\n"
"ПОВЕЗЛО ТАК ПОВЕЗЛО подборка ( нереальное везение ...\n"
"Видео по запросу повезло▶ 5:24\n"
"https://www.youtube.com/watch?v=TR-XlvXyVVk\n"
"9 июн. 2016 г. - Добавлено пользователем UGARPRIKOL\n"
"Подборка везений, удач, людей рожденных в рубашке, невероятные везунчики, нереальное везение, спасения, невероятные случаи, нереальные спасения, удивительные случаи ...\n"
"Повезло так повезло - YouTube\n"
"Видео по запросу повезло▶ 4:02\n"
"https://www.youtube.com/watch?v=0fCer7MSsGE\n"
"5 янв. 2016 г. - Добавлено пользователем CrazyLife\n"
"Текст повезло так повезло: Многие люди жалуются на судьбу, но не все знают что бывают случаи из категории повезло так повезло, вот часто такие случаи повезло...\n"
"Люди которым очень повезло - YouTube\n"
"Видео по запросу повезло▶ 13:33\n"
"http://www.youtube.com/watch?v=WT5rSmyDUPE\n"
"http://www.i-am-first.and-me-02.com\n"
"9 нояб. 2014 г. - Добавлено пользователем zrelishhe\n"
"Люди которым очень повезло. https://www.youtube.com/playlist?list=PLaAsJPdpb4MdBCu1s-990Zb0atgzMH-VC Каждый ...\n"
"Мне повезло - Перевод на английский - примеры русский | Reverso ...\n"
"context.reverso.net/перевод/русский-английский/Мне+повезло\n"
"Перевод контекст \"Мне повезло\" c русский на английский от Reverso Context: мне очень повезло, мне так повезло, мне не повезло, мне просто повезло.\n"
"Я думаю, мне повезло - Перевод на английский - примеры русский ...\n"
"context.reverso.net/перевод/русский-английский/Я+думаю%2C+мне+повезло\n"
"Перевод контекст \"Я думаю, мне повезло\" c русский на английский от Reverso Context: Я думаю, мне повезло, что Эмили не колдунья.\n"
"Тебе повезло - Перевод на английский - примеры русский ...\n"
"context.reverso.net/перевод/русский-английский/Тебе+повезло\n"
"Перевод контекст \"Тебе повезло\" c русский на английский от Reverso Context: повезло тебе, тебе не повезло, тебе очень повезло.\n"
"Ему повезло - Перевод на английский - примеры русский | Reverso ...\n"
"context.reverso.net/перевод/русский-английский/Ему+повезло\n"
"Перевод контекст \"Ему повезло\" c русский на английский от Reverso Context: Ему повезло я не делал промывание желудка.\n"
"25 человек, на голову которых свалилась огромная удача - AdMe\n"
"https://www.adme.ru/.../25-chelovek-na-golovu-kotoryh-svalilas-ogromnaya-udacha-...\n"
"21 ч. назад - 25 человек, которым крупно повезло, и они не смогли держать это в тайне · 10 034 · 12 «отвратительных» валентинок для тех, кто сыт по горло ванильными подарками · 11 990 · 6 важных нюансов, которыми стоматологи не спешат делиться с пациентами · 41 621 · 25 преподавателей, круче ...\n"
"Люди, которым \"немножко\" не повезло | NUR.KZ\n"
"https://www.nur.kz › ✔ Последние новости › Калейдоскоп\n"
"1 ч. назад - Удача, как известно, дама переменчивая и лучше с ней дружить, чем наоборот. Люди, которым \"немножко\" не повезло. Подборка, собранная для вас ниже, как раз о том, когда удача отвернулась и людям как минимум \"немного\" не повезло...\n"
"ПОВЕЗЛО GIF | ГИФКИ | ВКонтакте\n"
"https://vk.com/show_povezlo\n"
"ПОВЕЗЛО GIF | ГИФКИ запись закреплена. вчера в 23:45. Действия. Пожаловаться. БИОМУСОР - ЭТО САМЫЕ ОТБОРНЫЕ МАРГИНАЛЬНЫЕ ЛИЧНОСТИ В РЕЖИМЕ НОН СТОП. ТРЭШОВЫЕ ВИДЮХИ ПИКЧИ БЫДЛО С КОТОРЫХ ХОЧЕТСЯ СВАЛИТЬ С ЭТОЙ ПЛАНЕТЫ БИОМУСОР - https://vk.com/ ...\n"
"Вместе с повезло часто ищут\n"
"повезло перевод\n\n"
"повезло викисловарь\n\n"
"повезло это\n\n"
"повезло горбачева\n\n"
"повезло песня\n\n"
"повезло часть речи\n\n"
"повезло так повезло запятая\n\n"
"видео повезло песня\n\n"
"1 \n"
"2\n"
"3\n"
"4\n"
"5\n"
"6\n"
"7\n"
"8\n"
"9\n"
"10\n"
"Следующая\n"
"Казахстан Ауэзовский район, Алматы - Из вашей истории поиска - Учитывать мое местоположение - Подробнее…\n"
"СправкаОтправить отзывКонфиденциальностьУсловия")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.