using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d)(?:\.|-(\d))\s.*";
string input = @"37 4. Саб 1-2 Фам 53
37 5-6 Саб 1-2 Фам 51";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}