// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d)(?:\.|-(\d))\s.*").unwrap();
let string = "37 4. Саб 1-2 Фам 53
37 5-6 Саб 1-2 Фам 51";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}