package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?<area>[\d]{3})[-][\d]{2}[-][\d]{4})$`)
var str = `721-07-4426
000-00-0000
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}