$re = '/^((?<area>[\d]{3})[-][\d]{2}[-][\d]{4})$/m';
$str = '721-07-4426
000-00-0000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);