use strict;
my $str = 'lorem ipsum
active_targeted_decision={
decision="ROM_romanisation_campaign_subject"
target=1 ignore=no
days=0
state=available
}
lorem ipsum
\\blindtext
active_targeted_decision={
decision = "Some other decision"
}
';
my $regex = qr~active_targeted_decision\s*=\s*\{
[^{}]*
decision\s*=\s*"ROM_romanisation_campaign_subject"
[^{}]*
\}~mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}