$re = '~active_targeted_decision\s*=\s*\{
[^{}]*
decision\s*=\s*"ROM_romanisation_campaign_subject"
[^{}]*
\}~mx';
$str = 'lorem ipsum
active_targeted_decision={
decision="ROM_romanisation_campaign_subject"
target=1 ignore=no
days=0
state=available
}
lorem ipsum
\\blindtext
active_targeted_decision={
decision = "Some other decision"
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);