using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d{4})\/(\d{2,4})(?:\/(\w{2}))?(?!\S)";
string input = @"which seems to work properly, but I want to avoid the cases in which for example: I have a string ""2020/2000/WEEEE"" and it matches it.
Other wrong example that it matches: ""IEN/BSK-2020/143999"" .
4444/1234/en";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}