const regex = /\b(\d{4})\/(\d{2,4})(?:\/(\w{2}))?(?!\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d{4})\\\/(\\d{2,4})(?:\\\/(\\w{2}))?(?!\\S)', 'gm')
const str = `which seems to work properly, but I want to avoid the cases in which for example: I have a string "2020/2000/WEEEE" and it matches it.
Other wrong example that it matches: "IEN/BSK-2020/143999" .
4444/1234/en`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}