const regex = new RegExp('[^\\w\\s]|_', 'gm')
const str = `M'glad_%^&bach
1-text`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);