use strict;
my $str = 'M\'glad_%^&bach
1-text';
my $regex = qr/[^\w\s]|_/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";