#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(Course\d+)(?:(?!Course\d)[^])*?(?:No Name|(Name)|(?=Course\d))"
Local $sString = "------------ Course1 ------------" & @CRLF & _
"------------ foo ------------" & @CRLF & _
"------------ Name ------------" & @CRLF & _
"------------ Course2 ------------" & @CRLF & _
"------------ foo ------------" & @CRLF & _
"------------ No Name ------------" & @CRLF & _
"------------ Course3 ------------" & @CRLF & _
"------------ Name ------------" & @CRLF & _
"------------ foo ------------" & @CRLF & _
"------------ Course4 ------------" & @CRLF & _
"------------ No Name ------------" & @CRLF & _
"------------ Course5 ------------" & @CRLF & _
"------------ foo ------------" & @CRLF & _
"------------ Name ------------"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")