import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(Course\\d+)(?:(?!Course\\d)[^])*?(?:No Name|(Name)|(?=Course\\d))";
final String string = "------------ Course1 ------------\n"
+ "------------ foo ------------\n"
+ "------------ Name ------------\n"
+ "------------ Course2 ------------\n"
+ "------------ foo ------------\n"
+ "------------ No Name ------------\n"
+ "------------ Course3 ------------\n"
+ "------------ Name ------------\n"
+ "------------ foo ------------\n"
+ "------------ Course4 ------------\n"
+ "------------ No Name ------------\n"
+ "------------ Course5 ------------\n"
+ "------------ foo ------------\n"
+ "------------ Name ------------";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}