const regex = /^=\?(?<ifNull>(?:\\(\\\\)*:|[^:])*)(?<!\\):(?<ifNotNull>(?:\\(\\\\)*:|[^:])*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^=\\?(?<ifNull>(?:\\\\(\\\\\\\\)*:|[^:])*)(?<!\\\\):(?<ifNotNull>(?:\\\\(\\\\\\\\)*:|[^:])*)$', 'gm')
const str = `=?This value would be returned if null or empty.:This would be returned if not.
=?This\\:is\\:a\\:demo of what \\:happens\\:with:an escaped \\: separator.
=?This is what happens with an invalid value.
and don't forget the =? on the front of the string:or you won't get any results.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}