package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b\d*[a-z][a-z\d]*`)
var str = `Abcd abcd1a 5ever qw3-fne superb5 1234 0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}